Feedback Thread Firmware M0CR060 for the MX300

Bit Baby

Re: Feedback Thread Firmware M0CR060 for the MX300

+1. I thought it was related to access rights. I run the SE as Administrator, still no luck. In this day an age, I sould't have to deal with ISO files! SE should just work! What a disgrace for Crucial!!!!

Bit Baby

Re: Feedback Thread Firmware M0CR060 for the MX300

Trying to update the firmware via Storage Executive software in W7 Laptop and getting the below error. I thought the issue was the user access rights. So, I started SE as Administrator but still no luck. Manual Firmware update option is also useless!! The only way is to use the Boot CD. For that I have to change the BIOS etc... Pain in the neck!!! Still need to deal with this BS instead of running the Firmware Update through an Application like everybody else... Shame on you Crucial!!!

 

Firmware Update Error

 

Invalid Parameter

Folder C:\Users\username\AppData\Local\Temp\1513946105243-0 is an invalid firmware update directory!

Kilobyte Kid

Re: Feedback Thread Firmware M0CR060 for the MX300

My computer equipped with a MX300 525 is crashing and consistently showing an error related to the hard drive before crashing. I'm trying to install updated drivers using Storage Executive to fix the issue but getting the same exact error messages someone else mentioned earlier in this thread:

 

1) With 'Perform Live Firmware Update' unticked:

"Firmware Update Error

Folder"

 

2) With 'Perform Live Firmware Update' ticked:

"Invalid Parameter

Folder C:\Users\userNameHere~1\AppData\Local\Temp\1513732433130-0 is an invalid firmware update directory!"

 

 

Bit Baby

Re: Feedback Thread Firmware M0CR060 for the MX300

Exact same experience for me...

 

My computer equipped with a MX300 525 is crashing and consistently showing an error related to the hard drive before crashing. I'm trying to install updated drivers using Storage Executive to fix the issue but getting the same exact error messages someone else mentioned earlier in this thread:

 

1) With 'Perform Live Firmware Update' unticked:

"Firmware Update Error

Folder"

 

2) With 'Perform Live Firmware Update' ticked:

"Invalid Parameter

Folder C:\Users\{userNameHere~1}\AppData\Local\Temp\1513732433130-0 is an invalid firmware update directory!"

Kilobyte Kid

Re: Feedback Thread Firmware M0CR060 for the MX300

Google search of my Storage Executive error brought me here...I also have the "Firmware Update > Error Invalid Parameter > Folder C:\Users\Admin\AppData\Local\Temp\..." with PLFU ticked (I can't seem to untick it). 

Dell Latitude-E6510, Windows 10 Pro v1709 (x64) CT128MC100SSD1 (MU01).   Drive is encrypted with Bitlocker...could that be the issue?

 

Enable Momentum Cache did work (after the reboot it shows "Currently enabled..."   However, the Firmware Update error persists.

Bit Baby

Re: Feedback Thread Firmware M0CR060 for the MX300

I have exactly the same problem.

Windows 10 clean install with CSE Version: 3.50.102017.03

 

Anybody at Crucial listing?

Bit Baby

Re: Feedback Thread Firmware M0CR060 for the MX300

Same issue here!

JEDEC Jedi

Re: Feedback Thread Firmware M0CR060 for the MX300


bymy141 wrote:

 

 

Anybody at Crucial listing?


@bogdan has brought it to their attention in case they've missed it.  But it is Christmas so I'm not sure what response time there will be...

_______________________________________
How do I know what memory to buy?
Shop for your region: US | UK | EU | France | Global
I think my memory is bad. What do I do now?
FAQs and Top Forum Solutions
We want your feedback! Post in the Suggestion Box
Did a user help you? Say thanks by giving Kudos!
Still need help? Contact Customer Service
Want to be a Super User?
JEDEC Jedi

Re: Feedback Thread Firmware M0CR060 for the MX300


rjstephan wrote:

Drive is encrypted with Bitlocker...could that be the issue?


The update should work anyway. The Storage Executive User Guide says: 

• Encrypted drives (those with TCG-enabled/password-protected)—make sure the Perform Live Update option is selected, and then click Update Firmware Now.

 

Good question anyway.

______________________________________

FAQs and Top Forum Solutions
Did a user help you? Say thanks by giving Kudos!
How do I know what memory to buy?
Still need help? Contact Crucial Customer Service
Remember to regularly backup your important data!

Kilobyte Kid

Re: Feedback Thread Firmware M0CR060 for the MX300

Same thing here.  Running the latest version of Windows 10 64-bit with two MX300 525GB drives, M.2 and 2.5" installed.

 

I installed the online and offline versions of Java 32-bit & 64-bit. 

 

I copied the standalone Java 2017 "lib" and "bin" folders into the CSE java folder to replace the 2016 version included with CSE.  Tried with both the 32-bit & 64-bit files. (renamed the original CSE java folders bin.old and lib.old) No luck.  

 

I set them all to run as Administrator and tried Compatibility mode as far back as Vista with and without SPs. 

 

I saw "javaw.exe" and "jxbrowser-chromium.exe" running in Task Manager.  I set both to run as Administrator, tried compatability settings as well. 

 

The folder it created is based on the time it creates it.  I think the day of the month and miliseconds in the hour.

 

C:\Users\userNameHere~1\AppData\Local\Temp\1513732433130-0 -> 1513(day)(miliseconds)

 

I created the next 5,000 folder in the upcoiming range (excel and some comand-line work).  I set made sure to remove all read-only permissions and set full control to everyone for good measure.

 

Nothing changed.  Same error.  Booted the ISO off a USB, update successful.

 

Clearly a Windows 10 and Java perrmission issue with the user's "Temp" directory as this all runs inside Java.   Maybe the Java and JxBrowser processes can't write to that C:\Users\userNameHere~1\AppData\Local\Temp\1513DDMSSSSSS-0 directory after creating it?

 

If I had to guess:  Install full Java from Java's website > reboot > open Control Panel > Java > Security tab > Exemption Site List > Edit Site List > add http://localhost and/or http://127.0.0.1

 

I hope this helps narrow it down, but it's absurd for anyone to do any of this.  Samsungs magician is a breeze to update with, so fix it.

 Happy Holidays.