MAC emory Installation Problem

SOLVED
Highlighted
Bit Baby

MAC emory Installation Problem

I have a (late 2009) 27” iMac and purchased memory upgrade modules in hopes of going from 4 GB to 16 GB. I must have done something wrong because when I tried to boot it up it started to make this chime-like sound and the screen remained dark. After shutting down and ejecting modules, reinstalling the modules in different slots, rebooting, I got the familiar MAC start up sound, but this time repeatedly, and after a few minutes,a grinding noise that sounded like a paper shredder. Needless to say I shutdown and am desperately seeking help. Does anyone have a solution to this problem?
2 Replies
DIMMented

Re: MAC emory Installation Problem

First thing would be to unplug the power cord and remove the new memory.   Use compressed air to make sure the memory slots are clean.   Lots of dirt collects around them since air is pulled from the bottom.   It is possible some dirt got in there and is interfering with the memory.  Now install only your original memory, then stand the iMac upright.  You should also inspect the gold contacts on both sides of the new memory to make sure they look clean & shiny.

 

The noise you are describing has several causes unrelated to your memory issues.  If you powered on your iMac while it was lying flat on the table chances are you are hearing a CD/DVD making the noise.  Stand the iMac upright until you remove the CD/DVD.    See if your iMac will boot with the just the original memory installed.   Then verify there are no CD/DVDs in the optical drive.   If the iMac is still making the noise see if you can determine where on the iMac the noise is coming from and whether it is a physical noise from a device (drive or fan) or whether it could be distorted noise from the speakers (press the mute key).  The noise can really only be an Optical Drive issue, fan issue, hard drive or possibly an audio issue.  

 

Once you resolve the shredding noise issue or if it no longer makes the noise with the iMac upright, then you can troubleshoot your memory issue.   Make sure your system is turned off and is unplugged.  If you have any free memory slots, install one new memory module and boot the iMac to see if everything is Ok.  Make sure you are inserting the memory in the correct direction.  If it is hard to insert, you probably have it reversed.   If you have no free slots, remove one original memory module.   We want to test the new memory one module at a time to see which one might be causing the problem.

 

If it boots without any beeps, go into the Apple System Profiler and in the left column click on "Diagnostics" and see if any errors are listed in the right pane.   Then click on  "Memory" in the left column to make sure you see the new memory on the right side and it says "Ok" next to all of your installed memory.   The speed of all the memory should be the same.   You can access the Apple System Profiler by clicking on the Apple menu at the top left and holding the "Option" key and the first option should toggle to "System Information".   

 

If you get the beeps, then turn off & unplug the iMac and press on the new memory again to make sure it is fully inserted.  Sometimes it is difficult fully seating the memory as it can be awkward and hurt your fingers.   If it still fails, remove it and put it aside as potentially bad.    Now take the next memory module and repeat.   If all the new modules fail, then post the Crucial part number listed on the stickers of your new memory.   Also look to see if the label shows "For Mac" on it.    You can also remove one of your original modules and test one of the new ones in that slot  since we know that slot works with the original memory.

 

Repeat the whole process for each new memory module.

 

Also if you get the "beeps", please post how many there are in the sequence.   If there are long & short beeps, we need to know that as well.

Bit Baby

Re: MAC memory Installation Problem

Thank you for your reply. After reading your very thorough instructions, and after having so much difficulty with what should have been a simple memory installation procedure (it appears that I wasn't applying enough pressure to seat the modules correctly), I decided that this is way above my pay grade. Even more so since after the memory installation, I planned to install an SSD to replace my original hard drive. So I gave up and took it to an authorized Apple technician. Thanks again for your help.